NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ibcs2 on netbsd 4.0.1 vs. 5.1

In article 
Patrick Bennett  <> wrote:
>I am trying to get a legacy application written for SCO OpenServer
>5.0.x to run on NetBSD 5.1 under ibcs2 emulation and am having some
>First, I should point out that I'm doing this using guest virtual
>machines under linux kvm on Ubuntu 10.04.
>With NetBSD 4.0.1, I had success getting my legacy app to run right
>out of the box - my app ran with virtually no modification to the
>default installation.  I did not need to install shared libraries,
>re-compile the kernel, nada.  The only problems I did encounter with
>the application were related to the app's installation paths and
>permissions and once I got them correct the app ran well.
>On later versions of NetBSD, however, I have not had any success after
>many hours of reading docs, googling, tweaking things, etc..  The
>application simply sigfaults on execution seemingly no matter what I
>try.  On 5.1, amongst other things, I have tried recompiling the
>kernel with the COMPAT_IBCS2 option enabled and moving the app's
>directory tree under /emul/ibcs2 (this was not necessary on 4.0.1).
>Some months ago I tried all this on 5.0.1 and never got it to work
>either, though I've forgotten the details now.
>I have /not/ tried installing the shared libraries for two reasons: 1)
>they were not needed under 4.0.1, and 2) the script
>/usr/share/examples/emul/ibcs2/ibcs2-setup, which apparently copies
>the shared libraries off of a SCO installation cd, does not exist on
>the system as promised by "man compat_ibcs2" (as a matter of fact,
>there is not even an "ibcs2" directory on this path!); this script
>also does not exist on 4.0.1.
>Any one have any tips to get ibcs2 working again for my app as it does
>under 4.0.1, or on how to further debug?

Csn you ktrace it and see what it prints?


Home | Main Index | Thread Index | Old Index