NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD-5.1 running under Parallels VM on Mac OS X

(still sorting out networking issues at my new location, but mail
to/from the NetBSD lists seems to be going OK)

Today I tried booting installing and running NetBSD-5.1 on Parallels-5.

The install seemed to work quite well (very speedy with the CD image NFS
mounted over my network), though there was a strange "error" right at
the end of the newfs, IIRC.  See the first screen shot below.

The first time I tried booting with 2 CPUs enabled in the VM, it seemed
to get stuck at the point indicated in the second image below.  After
some fiddling around, including "suspending" the VM and restarting it,
then suddenly it worked.

Indeed suspending the VM allows the second CPU to spin up most of the
time (three times out of 4 so far :-)).  The one failure resulted in a
crash, but I failed to take a snapshot of the virtual screen.

However networking doesn't seem to work.  Running "dhclient ne2" causes
the system to mostly hang -- ^T and ^C and ^\ do nothing (though the
latter two will echo).  Eventually typed characters stop echoing.  Same
for bringing up the interface and then trying to run "tcpdump" on it.

I can't seem to force the system to go into DDB either, though this
might be a keyboard mapping issue.

I'd post a dmesg, but getting it off the virtual system without
networking is going to require writing it to a virtual floppy, or maybe
printing it to the virtual printer file.

                                                Greg A. Woods

+1 250 762-7675                VE3TCP          RoboHack 
Planix, Inc. <>      Secrets of the Weird 

PNG image

PNG image

Attachment: pgpX8NCxV5W0_.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index