NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Screen goes blank on me

I have a problem with NetBSD 5.1_RC4, not new to this RC4, of screenblank 
kicking in unwanted, after about 30 seconds of keyboard inactivity, and it 
doesn't come back in response to typing any key.  Only way I can get it back is 
to go to another virtual terminal blind, login as root if I haven't logged in 
already, and type 

screenblank -u

without seeing anything on the screen.

Also, when I go into X and then come back (quitting twm, I haven't installed 
anything else yet), all I can see on the screen is a rectangular cursor, and 
haven't found any way to get the screen back except by rebooting; "screenblank 
-u" doesn't work.  Only thing that works is type

shutdown -r now

without seeing anything on screen; that gets me out.  So the command-line 
interface remains functional but invisible.  Ctrl-L doesn't work.

This screen going blank never happened when booting the installation CD.

I think I had this problem with NetBSD 4.0.1 running on a 4 GB USB stick, but 
setting screenblank=NO in /etc/rc.conf seems to have fixed it.  I was even able 
to go into X with twm and come back to a working screen.

I have screenblank=NO in /etc/rc.conf and would like to know what I need to do 
to get screenblank to behave properly, or failing that, disable screenblank 
completely.  I've looked in the source code in /usr/src/usr.sbin/screenblank

Some things I haven't tried yet are:

1. Rename /usr/sbin/screenblank to screenblank-bad so it won't be found.

2. kill (or pkill?) -9 screenblank

3. chmod -x /usr/sbin/screenblank # render it nonexecutable

Could this be related to my devious means of booting NetBSD, using a 30 MB 
giant floppy image, ffsv1 file system, including netbsd kernel and made 
bootable using installboot?  I boot into FreeDOS and boot this image using 
grub4dos.  Since NetBSD 5.0.2, I get "Not a bootxx image" when trying to boot 
NetBSD normally, even after using installboot.  Also, would hang 
shortly into the boot, on the first line of screen output.

I do this also with NetBSD 4.0.1 because my BIOS, dating to 2001, does not 
support booting from USB.  I can also boot this USB stick from FreeDOS using, and have also booted this USB stick using FreeDOS, grub4dos and 
loading PLoP boot manager (


Home | Main Index | Thread Index | Old Index