NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Wireless LAN association failure


Sometimes, when traveling, I run into wireless networks where my NetBSD 
current running laptop absolutely refuses to associate. I'm in this situation 

"ifconfig iwn0 list scan" reports:

xxxxxx    00:0d:72:cc:01:29   11   54M 242:0    100 EPSB

and "wlanctl iwn0" gives me

iwn0: mac 00:0d:72:cc:01:29 bss 00:0d:72:cc:01:29
        node flags 0005<bss,scan>
        ess <xxxxxx>
        chan 11 freq 2462MHz flags 04e0<cck,ofdm,2.4GHz,dynamic cck-ofdm>
        capabilities 0471<ess,privacy,short preamble,pbcc,short slot-time>
        beacon-interval 100 TU tsft 839709184290 us
        rates *1.0 *2.0 *5.5 6.0 9.0 *11.0 12.0 18.0 22.0 24.0 36.0 48.0 
        assoc-id 0 assoc-failed 0 inactivity 300s
        rssi 205 txseq 1 rxseq 53376

I am using wpa_supplicant with the ssid entry configured for WEP. And I've also 
tried using direct ifconfig configuration (with nwid/nwkey).

Does any one see problem in the above data? Are there other parameters/data 
that I should be looking at?


Home | Main Index | Thread Index | Old Index