NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Virtual NetBSD installer hang

I'm in the midst of creating a bunch of virtual machines in order to check
portability of a project.  I've run into trouble with a NetBSD virtual machine.
 It hangs at boot in the installer.  I'm hoping that someone will recognize the
symptoms and give me a boost in the right direction.

The host machine is an amd64 running Linux (Fedora 13).  The guest is a KVM
machine with 1 virtual CPU and 2 GB of RAM.  I have tried turning off both ACPI
and APIC, but it has made no difference.  Other virtual hardware:
- Cirrus Logic video card with 9MB
- pcnet Ethernet card
- PS/2 mouse
- SB16 sound card (also tried with no sound card at all)

I have tried installing both NetBSD 5.0.2 and 5.1_RC2, with identical results. 
I also attempted to install 4.0.1, but the installer fell into a constant reboot
cycle almost immediately.  I couldn't see the console messages very well,
because they were visible for such a short time, but I saw something about a
timer manipulation resulting in a time in the future.

With both 5.0.2 and 5.1_RC2, these are the messages visible on the console when
it hangs.  The output and resulting hang are identical when using install
options 1, 2, and 3.

vga0 at pic0 dev 2 function 0: vendor 0x1013 product 0x00b8 (rev. 0x00)
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
drm at vga0 not configured
vendor 0x1af4 product 0x1002 (RAM memory) at pci0 dev 3 function 0 not 
pcn0 at pci0 dev 4 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c970A PCnet-PCI II rev 0, Ethernet address 52:54:00:63:3c:a9
pcn0: interrupting at irq 11
pcn0: 10base5, 10base5-FDX, 10baseT, 10baseT-FDX, auto, auto-FDX
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
attimer0 at isa0 port 0x40-0x43: AT Timer
pcppi0 at isa0 port 0x61
midi0 at pcppi0: PC speaker (CPU-intensive output)
sysbeep0 at pcppi0
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
attimer0: attached to pcppi0

I let it sit at that point for 15 minutes, just in case, but it never printed
another message.  If this is a known problem, a pointer to a discussion
somewhere would be greatly appreciated.  Thank you.

Home | Main Index | Thread Index | Old Index