NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: proplem with ntpd refclock and pps via parallel port

On 31 Jan 2010 at 16:08, David Lord wrote:

> proplem with ntpd refclock and  pps via parallel port
> Hi
> on a different system I have type 22 pps working
> ok from pps at ttl level to serial port. This seems
> very temperature sensitive possibly due to 
> incompatible input. Rather than add complication of 
> ttl=>rs232 level conversion I've connected pps to 
> parallel port and changed symlink to
> /dev/pps0 => /dev/lpt0
> With same kernel as on system working using pps 
> to DCD of serial port, but with above symlink,
> I was getting following in ntp.log at startup:
>   refclock_atom: /dev/pps0: Interrupted system call
>   configuration of failed
> A google for above here gave some messages from
> locals here (but 2005) suggesting use of 
> atppc* at isa?, ppbus* at atppc?, pps* at pps?
> so now I have dmesg with
>    atppc0 at isa0 ......
>    atppc0: capabilities=3<INTR,DMA>
>    ppbus0 at atppc0
>    lpt0 at ppbus0
>    pps0 at ppbus0
> I've just tried link pps0 => lpt0 and have same
> output from ntpd as before.
> How do I make /dev/pps0 and is this even working?
> Using a dm1488 ttl => rs232 chip and back to 
> serial port might be simpler.

Possibly this should be "sorry for the noise" as I've
just tried with symlink to /dev/tty00 and have exact 
same failure of refclock.

I'll try with parallel port on another system 
currently working ok with refclock via serial port, 
but no pps. I'm limited to what I can try as it's

I have other system that I originally tested with
refclock but that's a distance away but I can at 
least try with different kernel and feed in 1Hz 
from sig-gen.


Home | Main Index | Thread Index | Old Index