NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems after xorg patch to 5.0_STABLE

I updated my sources this weekend to pick up the xorg patch in 5.0_STABLE
and a number of things don't work right.  I've so-far installed on three
different i386 platforms w/different video devices.

Generic/OEM ATI rage128-32MB (r128 or ati driver)
Intel i915 w/8MB? (intel driver)
SiS 630AGP/shared-memory (16MB) (vesa driver)

  Can't switch vt's when X server is running (all systems)

  SiS/vesa system is glacially slow to paint the screen (you can watch
  it draw).  It used to be quick/normal.  The SiS driver caused X to die
  and leave the console unusable prior to the patch, so that's why the
  vesa driver is being used.  SiS driver worked fine in XF86-4.x.

  i915 system shows black squares for login/password prompt (and username)
  and status/error message appears in black box on xdm login widget.

  r128 system leaves text console in nearly-black-on-black when X server
  exits (or back when vt's could still be switched).  It was doing this
  before the patch as well, but I was hoping this would have been fixed.

All systems are still using the "/etc/X11/xorg.conf" file that was tailored
for them before the patch.

I tried generating one with "X -configure" on the i915 system, but it
failed.  I'll make note of the error when I get access to the machine
again--I ran out of time this weekend.

'xorconfig' is missing after the patch.  Is this deliberate?  It was
the only way to get a working configuration file on these machines.

Sorry for not including data.  I won't have access to those machines
again until next weekend.

Has anyone else had problems like these?  I didn't see any reports after
the request for tests (in which I couldn't participate--having no
experimental machines at present).


|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index