NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xenU install fails on newfs.

On Wed, Sep 02, 2009 at 09:02:26AM -0400, Glen Johnson wrote:
> > Nothing wrong here either. I would try without the second xbd attached to
> > cd0a, just to make sure the I/O error is not from the cd.
> >   
> I did just as you suggested and found the I/O error did disappear.  As I
> do mention in the next section I am getting further.  Newfs now succeeds
> but the cdrom is coming up Device not configured.  This is with device
> set to cd0a,

This is expected. All block devices shows up as xbd* in a PV guest.

> so then I tried xbd1a.  The cd could then be mounted but it
> never seems to find any of the sets.  I checked the path and it seems
> right.  I even exited out of sysinst, cd to /mnt2//i386/binary/sets,
> where the tgz files are, and did tar -tzf filename.  This came up with
> the same error as sysinst when it attempts to install the binary sets:
> gzip: can't read stdin: invalid argument

It could be that it's trying a 512-byte read, that is not properly converted
to a 2k read. I'm not sure how to deal with this one, there's no easy fix
I fear.

Manuel Bouyer, LIP6, Universite Paris VI.  
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index