NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xenU install fails on newfs.

Manuel Bouyer wrote:
> On Tue, Sep 01, 2009 at 09:48:05AM -0400, Glen Johnson wrote:
>> xbd backend: attach device vnd0d (size 4194304) for domain 2
>> xbd backend: attach device cd0a (size 117369) for domain 2
>> xbd backend 0x1 for domain 2 using event channel 23, protocol x86_32-abi
>> xbd backend 0x2 for domain 2 using event channel 24, protocol x86_32-abi
>> xbd IO domain 2: error 22
> Nothing wrong here either. I would try without the second xbd attached to
> cd0a, just to make sure the I/O error is not from the cd.
I did just as you suggested and found the I/O error did disappear.  As I
do mention in the next section I am getting further.  Newfs now succeeds
but the cdrom is coming up Device not configured.  This is with device
set to cd0a, so then I tried xbd1a.  The cd could then be mounted but it
never seems to find any of the sets.  I checked the path and it seems
right.  I even exited out of sysinst, cd to /mnt2//i386/binary/sets,
where the tgz files are, and did tar -tzf filename.  This came up with
the same error as sysinst when it attempts to install the binary sets:
gzip: can't read stdin: invalid argument
tar: End of archive volume 1 reached
tar: Sorry, unable to determine archive format.
On the hardware side of things I re-burned the install cd and replace
the cd rom drive with a different one.  Even with these things changed I
still get that, "xbd IO domain 2: error 22".
Getting closer.
>>> that's not the problem.
>>> Hum, now that I'm thinking about it, did you start your partition at
>>> sector 0 ? I always start mines at offset 63 (default value for x86).
>>> Maybe newfs tried to write to the mbr ...
>> I am not manually trying to run newfs.  It is sysinst that is attempting
>> to create the filesystem to install NetBSD on.  Do I need to set aside
>> slice /dev/wd0a with an offset of 63?
> Yes. If you created a mbr partition in sysinst before disklabel, it should
> already be there.
You are right, I did add the 63 sector offset for the first slice and
newfs now works. 
>> I know this is a different question but, it would make life much
>> easier.  Once an attempt at bringing up Xen DomU fails how do you reset
>> things to make another attempt at xm create conf -c?  Right now I have
>> to reboot do to my ignorance.
> xm list
> gives the list of currently running domains. If your domU is still here
> xm destroy it.
> Note that if you use 'halt -p', 'shutdown -p' or 'poweroff' in the
> domU it should dissapear from xm list by itself.
Wow, this helps a lot.  What a difference it makes not having to reboot
each time.

Home | Main Index | Thread Index | Old Index