NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Intel Enanched Speedstep support.


I just installed NetBSD 5.0 (i386) on Packard Bell BV IMEDIA MC 9611. I'm
finally happy with my box; it was a long time I didn't run NetBSD on my primary
desktop machine and I always felt that something was not at the right place
with GNU/Linux and FreeBSD. Now I'm happy, again.

Only two problems are getting me frustrated: the audio which doesn't works due
to a problem between my azalia(4) soundcard and the noapic support (indeed the
audio works properly when ACPI is disabled - I'll likely open a thread ad-hoc
for this problem), and the Speedstep support. It would be nice to also solve
the first problem but ATM I found the second one much more important. That's
why I'm forced to hair a nasty buzzing from the CPU fan which rotates at a
crazy speed. I can't tell you the exact RPM since, to be honest, I don't have
idea of what it is.

I tried to slow down the CPU speed by setting the frequency via sysctl(8) but
it seems I have no "machdep.est" options available:

        sysctl: second level name 'est' in 'machdep.est' is invalid

Nor I have any option about Speedstep support or others options discussed into
the CPU frequency scaling article[0] of the wiki. The dmesg(8) output also
don't say nothing about such feature. Due to this lack I discarded the idea to
install sysutils/estd to do some test, since I guess it won't works at all.

I also tried to disable a core via cpuctl(8) in order to slightly decrement the
CPU temperature but it's still higher than 50 grades and the fan speed still is
very high:

                               Current  CritMax  CritMin  CritCap     Unit
               temperature:     40.000                                degC
          cpu0 temperature:     58.000                                degC
          cpu1 temperature:     59.000                                degC

FWIW here is the output of cpuctl (command "identify") to the core 0:

        cpu0: Intel Core 2 (Merom) (686-class), 1862.14 MHz, id 0x6f6
        cpu0: features 
        cpu0: features 0xbfebfbff<PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX>
        cpu0: features 0xbfebfbff<FXSR,SSE,SSE2,SS,HTT,TM,SBF>
        cpu0: features2 
        cpu0: features3 0x20100000<XD,EM64T>
        cpu0: "Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz"
        cpu0: I-cache 32KB 64B/line 8-way, D-cache 32KB 64B/line 8-way
        cpu0: L2 cache 2MB 64B/line 8-way
        cpu0: ITLB 128 4KB entries 4-way
        cpu0: DTLB 256 4KB entries 4-way, 32 4MB entries 4-way
        cpu0: Initial APIC ID 0
        cpu0: Cluster/Package ID 0
        cpu0: Core ID 0
        cpu0: family 06 model 0f extfamily 00 extmodel 00

...and the relevant output of dmesg:

        cpu0 at mainbus0 apid 0: Intel 686-class, 1862MHz, id 0x6f6
        cpu1 at mainbus0 apid 1: Intel 686-class, 1862MHz, id 0x6f6

Useless to say that my CPU[1] *have* the Enhanced Intel Speedstep Technology.
Just I'm not able to make it works, yet. I tried to found informations on
Google, mailing lists and asked on IRCnet but without any results. This is my
last resource. Hope someone can point me to the right URI/document/man page.

Thanks in advance for your help and time!

Claudio M. Alessi

* References


JID: smoppy AT

Home | Main Index | Thread Index | Old Index