NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Panics from Huawei K3520 on NetBSD-5.0 (Vodafone Mobile Broadband)


I've been attempting to get a Huawei K3520 (E620?) to connect to
Vodafone mobile broadband.

Last night I plugged into the USB on a server, C3 Samuel 600MHz,
running NetBSD-5.0, which is in best location to get a good signal
and I had repeated panics. After the panics there was an error on 
boot that savecore was unable to copy the coredump to a file but 
manual run of "savecore -f -z -N /netbsd" seemed to work ok.

Previous day with same system there had been no such problem and
I'd been able to use "cu" to query the serial line although a chat
script and pppd terminated immediately after "CONNECT".

I then tried the K3520 on p4-2666 desktop running NetBSD-5.0 and 
that also gave a panic and again the previous day it had been ok.

Difference, I worked out, was that prior to the panics, I'd used
the K3520 from XP whilst prior to it being successfully attached 
I'd used it from Ubuntu. On plugging K3520 into desktop running
Ubuntu 9.04 and then back into NetBSD on same pc, there was no
longer a panic but this didn't work for the server on which I now
needed ACPI to be disabled before I had a successful boot although
previous day boot had been with ACPI enabled.

I then progressed to getting "CONNECT 7200000" but no routing and
eventually have IP connect to Vodafone but without dns although
the dns server ips obtained from the remote were same as I'd had
on Ubuntu. Of course DNS wasn't working from Ubuntu either but
seemed OK from Windows. The logs show ips as "MS-DNS". With a 
public dns I could eventually get some useful responses but many
timeouts. Pinging ip address of a server on my adsl broadband was
max of 2000 ms with ftp download at only 16 kB/s.

Query here is that the expected pppd <=> ttyU0 wasn't made, 
rather it was pppd <--> pts, char shunt /dev/pts/0. Is that to
be expected due to high connect speed of 7200000?

When service was first used a few months ago I had 200 - 300 kB/s
downloads although pings were still high, mostly > 500ms.  Today 
the signal strength is given as 14,99 (very good) but on XP I've
noticed it change over several minutes from very good to very poor
and back to very good without having moved position of the modem.
On Ubuntu this has caused reconnection with a different ip and
loss of any existing connection.

If anyone is interested I can try to obtain some information from
the coredumps if someone gives me a howto and I'll also include
options, chat and dmesg but too tired at moment.


Home | Main Index | Thread Index | Old Index