NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Help for a clueless audio-idiot!

On Tue, Apr 07, 2009 at 07:30:38PM -0400, Steven M. Bellovin wrote:
> On Wed, 8 Apr 2009 00:19:52 +0200
> Lubomir Sedlacik <> wrote:
> > On Tue, Apr 07, 2009 at 02:59:41PM -0700, Paul Goyette wrote:
> > > All I want to do is to take an MP3 file that sits on my hard drive
> > > and play it through a set of speakers (or headphones) connected to
> > > the back panel.  Should be easy, right?
> > > 
> > > So, I hook up the speakers and run audioplay.  Nothing happens.
> > 
> > audioplay(1) doesn't decode MP3.  You need something from pkgsrc to
> > play MP3 files.  E.g., audio/mad123 or audio/mpg123, if you want
> > something simple for a command line.
> > 
> or xmms under X, but you may need to put
>       export XLIB_SKIP_ARGB_VISUALS=1
> in your environment with xorg.

I know that Paul kind of asked for it, but he's not that much of a
moron.  Well, anyway.  Anybody who tried using audioplay(1) with a MP3
file knows that *something* happens.  Even more unpleasant than the way
the 128kbps MP3 itself sounds.

Paul, have you tried adding a bit of configuration in azalia_codec.c for
your codec?  Using the generic routines, you should at least get a few
names making sense for some of the controls in mixerctl(1) output.

Quentin Garnier - -
"See the look on my face from staying too long in one place
[...] every time the morning breaks I know I'm closer to falling"
KT Tunstall, Saving My Face, Drastic Fantastic, 2007.

Attachment: pgpuYiys7zpG4.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index