NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: HP Compaq DL385 with Smart Array 6/i

On Oct 1, 2008, at 5:01 PM, 
wrote: wrote:
On Oct 1, 2008, at 3:24 PM, wrote: wrote:

We've tried installing NetBSD 4.0 on 2 HP Compaq DL385 with single
dual CPU configuration and the Smart Array 6/i controller. The
problem that occur is that the I/O towards the controller/disk is

Even the installer writes -stalled- while installing/copying the
NetBSD base to the disk.

We've tried both NetBSD 4.0 i386 and amd64, and we've even tried
NetBSD current amd64 (during the summer), but it's the same symptom
all versions.

Has anybody else seen this problem before? are there any fixes or
workarounds available?


Hi Fredrik,

The power management on many of the Compaq DL series is terrible -
to get
NetBSD to boot you'll need to disable kernel support for ACPI. The
installer in
-current allows you to select a non-ACPI kernel from a menu, but for
NetBSD 4.0
I can't remember the magic incantation that boots with ACPI disabled.

Oh...we haven't tried that one yet (though now that you mention it,
it's something that has been suggested to solve other  problems then
running NetBSD on specific H/W.)
Thanks for the pointer. I'll try that as soon as I get time over.

I'll be interested to know if this solves your problem as I've got a DL385 that's about to be decommissioned (it runs Linux at the moment, but I'd like to repurpose it as a development machine with NetBSD on it). I came across the ACPI issue when I installed NetBSD on the older DL360 series - the install kernel would boot, but I couldn't access the disks, which sounds exactly like the problem you've been having. With ACPI support disabled, everything works
fine, including APM.

Hmm... I have bad news, it didn't solve the problem.
I grabbed the iso for amd64 HEAD 200809300002Z and tested the boot option [2] NetBSD (no ACPI) . The installation of comp.tgz + xcomp.tgz still gets the - stalled - message then the reach about 79% on the progress bar during the installation process. I also tried to run tar xzvpf manually on for instance pkgsrc.tgz, and it takes pretty long time before it's finished.

About the DL360, I run NetBSD 4.0 (i386) on one of those (but one of the latest versions) and that works pretty well. We have just decommissioned a DL380, so I will try out NetBSD on that one to see if NetBSD runs smoother.
(So we'll find out if it's only those DL 385 that have I/O problems).


Home | Main Index | Thread Index | Old Index