NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wpa_supplicant infinite scan

In article 
elijah rutschman <> wrote:
>Hello all,
>I have installed NetBSD/hpcmips 4.0 onto my NEC MobilePro 780.  Installation
>was a success, but I am having trouble with wpa_supplicant; it seems that
>the AP scan either never starts, or just hangs once it begins.
>my /etc/wpa_supplicant.conf:
>    ssid="MyAP"
>    proto=WPA RSN # I tried each of these individually as well
>    scan_ssid=0 # I have also tried 1, with no success.  my AP has SSID
>broadcast enabled
>    pairwise=TKIP CCMP # I tried each of these individually as well
>    group=TKIP CCMP # I tried each of these individually as well
>    mode=0 # I tried without this line
>    key_mgmt=WPA-PSK
>    psk="mykey"
>when I run:
>wpa_supplicant -d -i wi0 -c /etc/wpa_supplicant.conf, I get:
>Adding interface wi0
>Starting AP scan (broadcast SSID)
>pcmcia1: card irq 3
>and then the LED on the wireless card lights up and blinks, but nothing else
>happens on the screen until I send an interrupt to quit.  I found a similar
>reference from February in current-users,
>  I had
>previously installed NetBSD 3.0 on the MobilePro, and wpa_supplicant worked
>fine with the same card.  Can anyone shed some light on this?

There are problems with wpa-psk and wpa_supplicant both in the kernel and
in the program itself. Many of them have been fixed in /current.


Home | Main Index | Thread Index | Old Index