NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Unable to fsck 4.5TB FFSv2 fs

On Tue, 23 Sep 2008, Christos Zoulas wrote:
In article <>,
Stephen Borrill  <> wrote:
I have:

ld1 at aac0 unit 1: RAID 5
ld1: 4656 GB, 607897 cyl, 255 head, 63 sec, 512 bytes/sect x 9765867520

Which I formatted with:
newfs -O 2 -f 4096 -b 32768 -I -F -s 9765867520 /dev/rld1d

This worked fine, but apparently (the machine is at a customer's) it
locked and so they power-cycled it and thus it wants to fsck (NetBSD 4.0
so no WAPBL).

This is giving:
** /dev/rld1d
** Last Mounted on /usr/backup
** Phase 1 - Check Blocks and Sizes
cannot alloc 1243616332 bytes for inoinfo
Can you try this patch? It should reduce the total space needed, so if you die
in the second alloc, this should probably fix it. I have not tested it, so you
are on your own if it eats your disk, but visually it looks safe.

My first attempt tried to clear every inode which I think was down to an error in hand applying the patch (missed out the memset). So I newfsed and started again. The copy eventually died and the machine dropped to ddb:

So I then tried the correctly patched fsck_ffs and its demands have gone up!

** /dev/rld1d
** Last Mounted on /usr/backup
** Phase 1 - Check Blocks and Sizes
cannot alloc 4294967292 bytes for inoinfo


Home | Main Index | Thread Index | Old Index