NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Totally confused by Install Network Settings

Chavdar Ivanov wrote:
2008/6/18 Bryan Pierce <>:
      OK, I know this one!!!

IPv4 gateway:
      I think I know this one, but I could be wrong
      I believe this question wants my wireless routers IP            (But
from what I understand - the internet doesn't see my router's IP
             but my cable internet's "gateway's" IP address )

OK, just a brief summary.

Put your hostname in /etc/myname.

Put your router IP address in /etc/mygate.

Are you saying that I should interupt the install process and set these values (files)
or is this for after the install is complete?
If your network interface is, say, xyz0, create /etc/ifconfig.xyz0
with the contents:

!dhclient xyz0

This is over my head a bit, since I don't know what xyz0 would be ( I suppose
that by 'network interface' you mean the ethernet connection)
( I interupted the sysinstall and tried to look at the ifconfig file, but it looked like binary code - although I don't know a bleeping thing about Ed so it could be me)

Make sure /etc/nsswitch.conf has 'files dns' for hosts.

Your resolv.conf will be created by dhclient.

That's about it.

Although I'm still not sure if you're talking about setting up my system
after the install, or interupting the install and setting these values (and since
learning to this will be time-consuming, it makes sense to me to
ask  before getting knee deep in trying to mess with the system
settings (?)

After messing around for a couple more evenings, I'vd made some progress...

The IP for the network -- OK, I can't seem to turn DHCP off on my router, but what I was able to do is limit the DHCP range to 2 address - forcing the IP
   to a single, easily verifyable address.

Th IP of the of my ISP's name server =

I found instructions saying to interrupt the installer with '^y" and
perform the following.
   # ifconfig -a
Doing this confirmed my IP and submask settings, so I think I'm good there!

While I was here, I played around a bit and found out that that this works...
while this doesn't work...
So one thing that I know - The network connection is working fine!!

It seems pretty clear from these results, along with the fact that I'm seeing...
    "no address associated with host-name"
that the the problem there is a 99% chance that if I could get the system resolving
'domain names' that my problems would be solved.

There are still some questions, especially with "Host Name" and "Domain Name." I really don't think it's looking for "www" and "" in some order, but I think I'll leave off here, and hope that this will get me close enough that
I can figure the rest out on my own. :-)

And as always, your help so far is really, really, appreciated, and thanks in advance
for your future responses!!

Best Regards,

Bryan Pierce

Home | Main Index | Thread Index | Old Index