Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ThinkPad - suspend-to-RAM intel-x86 issues and tests

On Tue, Nov 20, 2018 at 06:02:36PM +0100, Riccardo Mottola wrote:
> Hi,
> wrote:
> > For general context, suspend does work on -current. I tried on an older
> > amd64.
> > (No driver disabled, but I tried from r/o root in an installer)
> > 
> > Unfortunately my shinier machine is a pain to suspend. I might end up
> > giving up.
> at least it works for somebody :) It works for me (mostly) also on my amd64
> Laptop. However, except for video issues, suspend works also on my T43, so
> basically suspend works also on x86.
> I am confused that disabling drivers does not help. One of the few drivers I
> did not disable (of course) are pci and ide! ANd I need a keyboard too for
> minimal tests...
> Other possible suspects?
> Riccardo
> PS: Do the install CDs or netinst CD's have ACPI enabled? Or do we have some
> sort of Live CD? Since using an USB key to boot proved not feasible to test
> without isntalling, if I had a CD image, Ic ould try at least on one or two
> devices more where I could even compare against another OS.

I was using a USB image to suspend, I dropped to boot prompt and ran
'boot -s' to boot to single user without a mounted rw filesystem.

Home | Main Index | Thread Index | Old Index