Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ThinkPad - suspend-to-RAM intel-x86 issues and tests

HI all,

I take the discussion started on a similar thread on netbsd-users over here, since it is still a "current" issue and to debug it I am using netbsd-GENERIV kernels from RelEng.

I am narrowing tests on two machines, a ThinkPad R51 (intel graphics) and a Thinkpad T30 (ATI graphics). They run 8 userland, have a current kernel to test. The test involves currently booting up... and disabling stuff to determine what is causing issues.

I tried disabling:
- isa
- fxp
- radeon
- audio

with no help.

Then Christos suggested me to disable "audio" and "video". I tried disabling both things and this is the result of putting things to sleep from console right after boot:

The R51: The result is... a black screen with no sleep indication a spinning fan, but no reboot either.. even waiting. Caps-lock doesn't | work, power-button neither (had to hold 5 seconds)

The T30 instead spits out a kernel panic message which I already posted, now I captured it on phot and it is updated to a current kernel.

the question is again.. suggestions on what to disable, if you have patch suggestions, etc.


Attachment: IMG_1942.JPG
Description: JPEG image

Home | Main Index | Thread Index | Old Index