Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

panic in Linux emulation [was Re: 6.99.32: panic when starting X]

On Sun, Feb 23, 2014 at 10:41:06AM +0100, Thomas Klausner wrote:
> After updating from 6.99.31/20140215 to 6.99.31/20140221, I started X
> and got a panic:
> fatal protection fault in supervisor mode
> trap type 4 code 0 rip ffffffff808dbe2c cs 8 rflags 13286 cr2 
> ffff80023b989000 ilevel 0 rsp fffffe813ba2e9b0
> curlwp 0xfffffe813ba139c0 pid 328.1 lowest kstack 0xfffffe813ba2b280
> panic: trap
> cpu8: Begin traceback...
> vpanic() at netbsd:vpanic+0x1cd
> panic() at netbsd:panic+0x43
> trap() at netbsd:trap+0xd86
> --- trap (number 4) ---
> usb_allocmem_flags() at netbsd:usb_allocmem_flags+0x6c
> ehci_allocm() at netbsd:ehci_allocm+0x2a
> usbd_transfer() at netbsd:usbd_transfer+0x6f
> usbd_open_pipe_intr() at netbsd:usbd_open_pipe_intr+0xf6
> uhidev_open() at netbsd:uhidev_open+0xa0
> ums_enable() at netbsd:ums_enable+0x41
> wsmuxopen() at netbsd:wsmuxopen+0xcd
> cdev_open() at netbsd:cdev_open+0xbd
> spec_open() at netbsd:spec_open+0x17f
> VOP_OPEN() at netbsd:VOP_OPEN+0x43
> vn_open() at netbsd:vn_open+0x2f2
> do_open() at netbsd:do_open+0xe9
> sys_open() at netbsd:sys_open+0x49
> syscall() at netbsd:syscall+0xb3
> --- syscall (number 5) ---
> 7f7ff4a3b46a:
> cpu8: End traceback...
> After a reboot I tried again (while logged in via ssh, not via the USB
> keyboard like before) and it worked.

I could also start from the console, so it seems to have a random

Why did I need to start so soon? Because of a second panic.

panic: kernel diagnostic assertion "len <= LINUX32_ELF_AUX_ENTRIES" failed: 
file "/archive/foreign/src/sys/compat/linux32/common/linux32_exec_elf32.c", 
line 244 
cpu7: Begin traceback...
vpanic() at netbsd:vpanic+0x1cd
kern_assert() at netbsd:kern_assert+0x5a
linux32_elf32_copyargs() at netbsd:linux32_elf32_copyargs+0x407
execve_runproc() at netbsd:execve_runproc+0x3da
sys_execve() at netbsd:sys_execve+0x53
syscall() at netbsd:syscall+0xb3
--- syscall (number 59) ---
cpu7: End traceback...
uvm_fault(0xfffffe886808b5e8, 0x0, 2) -> e
fatal page fault in supervisor mode

This happened during a bulk build, I guess building one of the suse
packages. I'll retry.

Home | Main Index | Thread Index | Old Index