Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: READ ME: updating mpc, mpfr, and eventually gmp

from Paul Goyette:

> I've had intermittent similar problems with NetBSD for at least three
> years now.  I have no idea what the problem is, though.  I've
> suspected some sort of memory corruption, but was never able to make
> any progress in tracking it down.

It could be a corruption or bug in NetBSD.  I've come to expect these
things with NetBSD.

This is in particular a sudden inability to build NetBSD-current from source.

Until I see information about an update of base gcc, I don't plan to try
any more using base gcc.  I could try to build gcc-aux or gcc48 from pkgsrc
and use that, if build is successful.  I think I could set HOST_CC and
HOST_CXX to tell the build to use that in place of base gcc.

I could also try to cross-build from FreeBSD using gcc-aux from ports 
or from NetBSD 6.1_STABLE if that boots.  Base gcc in FreeBSD through 9.x
is 4.2.1 because that is the last release before gcc went to GPLv3.

So there are things I can try before putting it on the back shelf.


Home | Main Index | Thread Index | Old Index