Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: gtk3, libXi vs xextproto


Patrick Welche wrote:
On Wed, Sep 25, 2013 at 04:29:46PM +0200, Riccardo Mottola wrote:
If I look for all xi.pc files, this is what I find:

bash-4.2# find . -name xi.pc
$ ls -l /usr/pkg/share/x11-links/lib/pkgconfig/xi.pc
lrwxr-xr-x  1 root  wheel  30 Jul 12 00:38 
/usr/pkg/share/x11-links/lib/pkgconfig/xi.pc -> /usr/X11R7/lib/pkgconfig/xi.pc

Maybe go back to Thomas' earlier questions? If you are using native X11,
gtk3 shouldn't be causing libXi to be built. Did you change X11_TYPE at
some point?
It shouldn't. I tried to build libXi myself since I saw the link failure. I caused confusion, sorry. It is thus correct that it was not pulling it in and I should not have tried to build it.

I would rephrase: gtk3 doesn't build with my native libXi.

Now perhaps my native libXi is too old? it has the same verison as yours though.


Home | Main Index | Thread Index | Old Index