Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ahcisata & pmp (was: Re: amd64-current (still?) won't boot (another one))

On Wed, Dec 12, 2012 at 01:07:36PM +0100, Manuel Bouyer wrote:
 > On Tue, Dec 11, 2012 at 06:51:12AM +0000, David Holland wrote:
 > > [...]
 > >  > there is a aprint_debug() in ahci_exec_fis() with some values that
 > >  > should give details about what failed; can you post it ?
 > > 
 > > It will be probably this weekend before I can try another test kernel.
 > > (I did try booting more verbosely at the time, but this caused the
 > > ahcisata stuff to be scrolled off by a ton of crypto messages.)
 > [...]
 > Assuming FreeBSD can probe your drive, can you try the attached patch ?
 > I don't know why it would matters, but FreeBSD has this delay ... as it turned out, I never managed to find time to test this
before today. So the first thing I did was try today's current without
hacks or patches, and... it worked. I guess ahcisata_core.c -r1.47
must have fixed it? That doesn't really make sense, but there don't
seem to be any other relevant changes besides that one.

Anyway, this issue can be forgotten I guess. I don't think I ever got
around to filing a PR on it.

David A. Holland

Home | Main Index | Thread Index | Old Index