Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

wine-devel upgrade needed? [ Error: _res is not supported for multi-threaded programs.]

On Sat, Mar 30, 2013 at 04:30:25PM +0530, Mayuresh wrote:
> On Sat, Mar 30, 2013 at 09:11:45AM +0100, Martin Husemann wrote:
> > You need to fix the code that tries to use the global _res.
> > Most likely it is severely broken (which is why the error has been
> > made explicit).
> > 
> > If it applies proper locking, it should not use _res - just change it to
> > declare its own variable instead.
> I find two modules in wine-1.3.26 that refer to _res:
> ./dlls/dnsapi/query.c ./dlls/iphlpapi/iphlpapi_main.c

BTW, I find wine-devel a little old. This issue might be fixed in later
wine versions.

Is any work in progress to upgrade wine-devel?


Home | Main Index | Thread Index | Old Index