Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: HEADS UP: Postfix 2.9.5 imported

On Sat, 05 Jan 2013 19:39:10 +0000
Matthias Scheler <> wrote:

> >Do you know of any reason why has "inet_protocols = ipv4" at
> >the bottom? (I assume it came from upstream.)
> Hello,
> Yes, that came from upstream. Not sure why. Maybe we should change it back?

I think so. The RELEASE_NOTES say:

[Incompat 20110918] The following changes were made in default
settings, in preparation for general availability of IPv6:

- The default inet_protocols value is now "all" instead of "ipv4",
  meaning use both IPv4 and IPv6.  

  To avoid an unexpected loss of performance for sites without
  global IPv6 connectivity, the commands "make upgrade" and "postfix
  upgrade-configuration" now append "inet_protocols = ipv4" to when no explicit inet_protocols setting is already present.
  This workaround will be removed in a future release.

Reading the above, I don't know why it was added to the in the
postfix source, but then again, I won't claim I understand the postfix
installation/upgrade process. :)

Kind regards

Home | Main Index | Thread Index | Old Index