Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: firefox not starting

On Mon, Mar 05, 2012 at 11:36:49PM +0000, Chavdar Ivanov wrote:
> There was a recent thread about the same which lead to a weird
> conclusion - it worked for ulimit -s set to 8191 and stopped for any
> value above that... Anyway, ulimit -s on the amd64 system I tried it
> on was 4096, so it was expected to work (modulo the version it was
> tested on, which might have been some released 5.x ).

Thanks for the tip.
I've played around with this a bit, and now it works:
# ulimit -s
# ulimit -s 8192
# firefox
# ulimit -s 20000
# ulimit -s      
# firefox        
# ulimit -s 2000 
# firefox       
# ulimit -s 1000
# firefox      
# ulimit -s 500
# firefox      
# ulimit -s 200 
# firefox      
LoadPlugin: failed to initialize shared library 
[/usr/pkg/lib/netscape/plugins/ unrecognized file format2 [1 
!= 2]]

and it started. It dumped core when opening my ~15 "daily" bookmarks though.
Opening them one by one is fine though; but even a second one might kill it.

(15 tabs)
zsh: segmentation fault (core dumped)  firefox
# firefox
(second tab)
zsh: illegal hardware instruction (core dumped)  firefox

ulimit -s 300 also works.


Home | Main Index | Thread Index | Old Index