Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: X server freeze/crash problem


I can rlogin into the laptop. The kernel works, interestingly, it is a bit bogged down. Top shows no process consuming cpu, but load is high. After a bit it setteld, I can even type this email.

ps -ax shows no "X", or xinit process running.

I thus tried to run "startx" from remote. It recovers and I get a working X session!

Then I run the incriminated application, again, it crashes. I get on the console:
xinit: connection to X server lost
X connection to :0.0 broken (explicit kill or server shutdown).
wmaker warning: got signal 1 - exiting...

then high CPU usage which I cannot trace if not when looking at "uptime" or "top", no particular process consumes it however. After a while it goes down and everything is fine again.


On 01/17/12 12:56, David Brownlee wrote:
On 17 January 2012 08:17, Riccardo 
Mottola<>  wrote:

using NetBSD current kernel and current userland, I can get X11 freeze in a
strange way. I don't know if this happened with 5.1 release, because the
intel card did not work, that is why I switched to current.

I open an image display application (LaternaMagica of GNUstep) and load
fairly large images to display.

The whole X server will feeze, display total garbage made of rainbowed
stripes except for the mouse cursor which displays fine, but frozen. The
kernel is not frozen, I can power down the laptop by its power button.

I cannot  however type anything and switch consoles.

There may be a bug in the application (which however, works on other
computers, even less-powered ones) but it should not be able to knock out my
X server.
Just curious, but if you are sshed into the laptop does that session
continue OK? Can you restart xdm/X?

Home | Main Index | Thread Index | Old Index