Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

X11 strangeness: amd64, FC15 remote display

I got a chance to install NetBSD/amd64 on a machine with an intel Core2
Duo processor and an nVidia dual-output video card.

I'm certain that right after installing (from a releng build about 2
weeks ago, I think 29 September) that X11 worked fine without any
"xorg.conf" file even though 'X -configure' complained about the
number of screens defined not matching the number of devices found.

The "xorg.conf" it generated seemed mostly sane, although it generated
2 "Device" sections, one for the "nv" driver and one for "vesa", both
pointing to the same device with separate "Screen" sections each pointing
to the separate (yet effectively same) "Device" entries.  I fixed it up
so that it only had one screen pointing at the "Device" section with
the "nv" driver, but when I tried to use it, it complained that it
couldn't find any devices and therefore no screens.

I saw a fix for what seems to be the same complaint come out a few days
ago and I updated sources and built a new release, but it made no
difference on my host.  Furthermore, now (again without any "xorg.conf"
file) the X server starts, but I have no keyboard or mouse at all
(USB-only intel board).  I'm in the process of building it again
after another update.

In the meantime, my usual solution to such things is to use another
system with a working X11 and do the headless clienthost thing.  This
worked OK when my serverhost was my laptop running NetBSD/i386-5.1_STABLE.
Other machines at my disposal are running Fedora Core 15 Linux and it's
prompting strange behavior from the NetBSD/amd64 clienthost.

I have the FC15's display :0 local.  Whether starting a "real" X server
or using 'Xnest' as display :1 and querying the NetBSD/amd64 clienthost,
trying to open applications from the menu of 'fluxbox' elicits a message
indicating that it tried to open on display :0, e.g.: "urxvt: can't open
display, aborting." or, "xterm Xt error: can't open
display:".  The DISPLAY environment variable clearly
says "".  Applications started through my custom
'.xsession' file, or from a shell/terminal open OK.

Also, using 'Xnest' on the FC15 serverhost, the cursor keys produce
odd effects.  Up-arrow appears to attempt to invoke 'lpr' and the
rest appear non-functional, the editing keys generate odd character(s)
and the right Control key produces a tilde ('~').

Is anyone else seeing similar things?  (Guess it's time to learn to use
'tmux'... ;)

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index