Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PAE vs. NFS server

On Wed, 2 Mar 2011, Jean-Yves Migeon wrote:

On 01.03.2011 17:08, John D. Baker wrote:
So, some great progress (no panics), but not quite solved (NFS server

Thanks for the report.

If you have the occasion, could you test with a MONOLITHIC kernel
together with than a GENERIC, for i386 (same release), please? If you
observe any difference in behavior, don't hesitate to ping me.

I just tried the recently-bumped 5.99.48, including MONOLITHIC and plain
GENERIC.  The results are interesting.

If I booted any kernel in single-user mode (-s) and simply exited the
shell so that it continued with multi-user boot the machine would hang,
completely unresponsive, with the display contents skewed after starting
'inetd' (it might have been while trying to start the in-tree 'httpd'
which I run on the machine in question).  My GENERIC+PAE kernel hung
the same way, but while trying to start 'mountd'.

Pressing the power switch made it claim that it was syncing disks, but
it just stayed hung.  I had to hold down the switch and force the machine

If I allowed the system to go multiuser without interruption, all worked
fine (except the PAE-enabled kernels still produce a broken NFS server).


GENERIC_PAE (my own that just includes GENERIC and sets "options PAE")
SHADOW (my custom pared-down kernel)
SHADOW_PAE (as above with "options PAE")

Also, trying to boot XEN3PAE_DOM0 kernel with xen-3.3.2 from pkgsrc
spews out a stream of "exit" messages and hangs (anything before the
first "exit" goes by too fast for me to see).

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index