Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

PAE vs. NFS server

Previously, in a thread starting with:

I described how i386 kernels with "options PAE" would panic when any
NFS server software (including 'amd') was started.

I tried again today with a 5.99.47 kernel build from sources updated
approximately 201103011350Z.

My first attempt to boot a kernel that was simply GENERIC with PAE
enabled failed with the message:

heap full (0x4f570+4096)

and severel hundred more lines of "exit" before finally hanging.

I tried again with my usual custom kernel but with PAE enabled and it
booted successfully, went multiuser and started NFS-server software
(amd, mountd, nfsd) without complaint.

I tried the GENERIC w/PAE kernel again and it booted this time and went
multiuser, but 'mountd' hung when attempting to start it.  Hitting
control-C aborted it and everything else came up OK.

Rebooting my custom+PAE kernel again (which started all NFS server
programs without complaint), I noticed that 'amd' worked OK, but my
remote NFS clients' requests were not being answered.

Rebooting my non-PAE custom kernel restored working NFS server

So, some great progress (no panics), but not quite solved (NFS server

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index