Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Recent netbsd-5 changes seem to make (autoconfig) raidframe trouble (Greg Oster) writes:

>The issue with version numbers is that they are broken with respect to
>component labels -- the versioning checks currently check for
>equialency, rather than "<=" some version number.  That means that if
>we bump the version number, then we end up writing out component labels
>which are no longer compatible with older kernels :(

You would need to create the new version only if the new fields
are non-zero. Old kernels couldn't handle such disks anyway.

                                Michael van Elst
                                "A potential Snark may lurk in every tree."

Home | Main Index | Thread Index | Old Index