Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src/sys/dev/usb

On Tue, 27 Jul 2010, Michael wrote:

> This reminds me - I have trouble with a Sun Blade 2500 and its onboard ohci (
> an Acer M5237 ) - a keyboard that works fine in the OF console will stop
> working once the kernel boots unless you plug it into a different port, the
> probe on the original port times out with uhub1: device problem, disabling
> port 1.
> Any idea what to look for? The root hub registers show the keyboard is present
> and powered up. I looked at linux and openbsd for blade 2500 specific
> workarounds but couldn't find any. I also tried a non-Sun keyboard with the
> same result. An ohci/ehci card doesn't show the problem but then again, it's
> not initialised by the firmware. Also, I don't see it on any other machine
> with onboard ohci ( like my G4 ) so it must be either something Sun's firmware
> does different than anyone else or something weird in the M5237 but that's a
> bog standard PC part.

ISTR the on-board hub is not USB2 so when you plug a USB2 device into it 
things don't work.


Home | Main Index | Thread Index | Old Index