Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src/sys/dev/usb

Hash: SHA1


On Jul 27, 2010, at 9:34 AM, Jonathan A. Kollasch wrote:

On Tue, Jul 27, 2010 at 12:09:25PM +0200, Matthias Drochner wrote: said:
Bus activity shows that Windows will preform a device reset after
requesting the initial descriptor, and before setting the address.

Yes I know -- while I don't have a bus analyzer I've read it

As our code is now, we set the address immediately after getting the
initial descriptor.

It has been that way since Jun 22 2008. My change only modified
the request size which was 8 bytes fixed length before and is 64
bytes with shorter accepted now.
Anyway, does the attached patch change anything for you?

Looks sufficiently like Windows on ohci(4) and ehci(4) for me.

(The reset code in the uhci root hub emulation also doesn't
look that correct btw.)

This reminds me - I have trouble with a Sun Blade 2500 and its onboard ohci ( an Acer M5237 ) - a keyboard that works fine in the OF console will stop working once the kernel boots unless you plug it into a different port, the probe on the original port times out with uhub1: device problem, disabling port 1. Any idea what to look for? The root hub registers show the keyboard is present and powered up. I looked at linux and openbsd for blade 2500 specific workarounds but couldn't find any. I also tried a non-Sun keyboard with the same result. An ohci/ehci card doesn't show the problem but then again, it's not initialised by the firmware. Also, I don't see it on any other machine with onboard ohci ( like my G4 ) so it must be either something Sun's firmware does different than anyone else or something weird in the M5237 but that's a bog standard PC part.

have fun

Version: GnuPG v1.4.7 (Darwin)


Home | Main Index | Thread Index | Old Index