Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Strange behavior on new machine (ioapic, nfs)

On Mon, Jun 21, 2010 at 07:12:11PM +0100, Patrick Welche wrote:
> On Mon, Jun 21, 2010 at 05:54:55AM -0700, Paul Goyette wrote:
> > Problem #2 is an issue with nfs (client).  Because of #1, I have
> > added a USB-based network interface for temporary connectivity.  I
> > can ping across this interface to my nfs server without any problems
> > (including large, 2k+ byte pings), and I can mount the remote file
> > systems.  I can even do a ``df'' to see the mounted file systems.
> > But as soon as I try to access a file on the remote fs, all access
> > to that fs, including a new ``df'', hang in tstile.  Even while the
> > fs is hung, I can still ping between the nfs client and server.
> All I can say is "me too". I am trying to netboot a poweredge R200, which
> has two bge0 Broadcom BCM5721. Tried both NetBSD-current/amd64 and i386.
> The NFS server is NetBSD-current/amd64 with nfe0.
> Netbooting OK up to point where root partition needs nfs mounting. I can
> use a root partition on a CD. Can mount the nfs root partition on /mnt.
> chroot /mnt then hangs, or tar -xzvpf - from tar files on nfs mounted
> partitions hangs. tcpdump shows 17 byte udp packets sent every now and
> then from server to client. Nothing else is going on. (no response from
> client back to server).

All run NetBSD-current/amd64, and the nfs server has hw checksumming
enabled, and

server nfe0 <---> netgear gigabit switch <---> netboot client bge0
              1G                           1G

works - all gigabit.

server nfe0 <---> netgear gigabit <---> 3com 4400 <---> netboot client bge0
              1G                   100M            100M

fails as per paragraph above. Same work/fail pattern observed with a client
with wm0 instead of bge0.

server nfe0 <---> netgear gigabit <---> 3com 4400 <---> netboot client bge0
              1G                   100M             1G

also fails. (Next is to try another switch instead of 4400 to see if
it is number of hops - 4400 is one of the main lab switches, and everyone
else is happy - tried different ports)



Home | Main Index | Thread Index | Old Index