Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: get usb device descriptor through ioctl?

On Wed, 10 Feb 2010, thomas nivelet wrote:
> Opening each endpoint (/dev/ugen0.xy) give me the same error... I read
> in the man that ugen is linked to device which don't have a driver but
> the dfu device I try to access (an OpenMoko Neo Freerunner) is linked
> against umodem0 and the other usb device connected to my computer are
> linked against umass0 and uvideo0, but trying to create this device on
> /dev with MAKEDEV give the error "unknown device".

Exactly what arguments did you pass to MAKEDEV?  If you tried something
like "MAKEDEV umodem0" then that won't work.  The umodem(4) man
page refers to the ucom(4) man page, which says that the files are
/dev/dtyU? and /dev/ttyU?.  You have to read the MAKEDEV script itself
to figure out that a command like "MAKEDEV ttyU0 ttyU1 ttyU2" will
create all of the /dev/{tty,dty,cty}U[012] devices.

Similarly, by following references form the umass(4) man page, you can
learn that the device files should be /dev/[r]sd* or /dev/[r]wd*.  For
the uvideo driver, I think the video(4) man page is incorrect, and the
device files should be /dev/video*, not just "/dev/video".

--apb (Alan Barrett)

Home | Main Index | Thread Index | Old Index