Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

when using WAPBL (mount -o log)

Dear devels,

i got this when using WAPBL logs (under current) on my ffs after a while or 
 - when i have created a log by 
        mount -o log 
after next reboot of the machine: 

panic: kernel diagnostic assertion "(*vpp)->v_type == VNON" failed: 
file "/root/netbsd/src/sys/ufs/ffs/ffs_alloc.c", line 808
fatal breakpoint trap in supervisor mode
trap type 1 code 0 eip c03931cc cs 9 eflags 246 cr2 b9000000 ilevel 0
Stopped in pid 1400.1 (mysqld) at       netbsd:breakpoint+0x4:  popl    %ebp

and here is my /etc/fstab:
/dev/xbd0a      /               ffs     rw              1 1
/dev/xbd0b      none            swap    sw,priority=1   0 0
/dev/xbd2a      none            swap    sw              0 0
kernfs          /kern           kernfs  rw
procfs          /proc           procfs  rw,noauto
/dev/xbd1a      /var            ffs     rw,noatime      1 1

with logs enabled:

/dev/xbd0a      /               ffs     rw,log              1 1
/dev/xbd1a      /var            ffs     rw,log,noatime      1 1

then the machine is crashing earlier (same error message).

I did a fsck_ffs -c4 /dev/xbd0a some weeks ago as mentioned in UPDATE.

Seems we have to wait until 5-RELEASE for using WAPBL logging for productional 

Many thanks and 
best regards,


  Niels Dettenbach
  Syndicat IT&Internet
  T.-Muentzer.-Str. 2, 37308 Heilbad Heiligenstadt - DE
  PGP public key ID 651CA20D
  Fingerprint: 55E0 4DCD B04C 4A49 1586  88AE 54DC 4465 651C A20D

Attachment: signature.asc
Description: This is a digitally signed message part.

Home | Main Index | Thread Index | Old Index