Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: i386 and the COMPAT_50 option

On Sun, Jan 25, 2009 at 04:56:03PM +0100, Quentin Garnier wrote:
> On Sun, Jan 25, 2009 at 03:12:43PM +0000, Andrew Doran wrote:
> This is not an option.  A binary can be linked to a library which will
> use compat code.  It's different from actual emulations because you
> can't e.g. link a linux library with a NetBSD program.

Indeed.  At present, I am using such a library which was compiled for
NetBSD 3 or possibly for NetBSD 2.  Unless I want to pay around $50,000
I cannot get source from the vendor; unless I ship enough units with the
library they gave me, I can't persuade them to build me a library on
modern NetBSD.

This is an ELF shared object and it actually works fine with the NetBSD 5
libc, and loaded by a native NetBSD 5 executable.


Home | Main Index | Thread Index | Old Index