Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

upgrade from 4.99.x to 5.0_BETA (problems with perl and openoffice)

I didn't check yet if same problems happen from official 4.0 or 4.0.1 
release going to 5.0_BETA. This is on amd64.

But when I moved from 4.99.73 to 5.0_BETA (Dec. 20), both openoffice2-2.41 
and perl-5.8.8nb8 stopped working.

 $ openoffice.org2.4                                                            
 [1]   Abort trap (core dumped) "${sd_prog}/${sd...

 (gdb) bt
 #0  0x00007f7ffa232f4a in kill () from /usr/lib/
 #1  0x00007f7ffa2d87b9 in abort () from /usr/lib/
 #2  0x00007f7ffcc8cfa1 in tools::extendApplicationEnvironment ()
    from /usr/pkg/OpenOffice.org2.4.1/program/
 #3  0x0000000000427b1f in main ()

And perl5 frequently says:

  panic: MUTEX_DESTROY (22) [perlmain.c:105] during global destruction.

Are these known problems?

Where is it documented? (Or where will it be documented?)

I did look at src/UPDATING (for 5.0_BETA).

Any other software known to break when upgrading from 4.99 to 5.0?

Any other software known to break when upgrading from 4.9 to 5.0?

Jeremy C. Reed

p.s. One thing that was fixed was postfix -- it now works by default to 
send outbound email without making any configuration changes. So if 
someone assumes they aren't using any outbound mail, it may start and 
attempt to send or bounce any old queued emails.

p.p.s. I am now going to perl-5.10.

Home | Main Index | Thread Index | Old Index