Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index] on DragonFly, sh detection for HOST_SH, and configure cannot guess build type (on 5.0_BETA) has:

 [ -z "${HOST_SH}" ] && HOST_SH="$(
        (ps -p $$ -o comm | sed -ne '2s/[ \t]*$//p') 2>/dev/null )"

"comm" is unknown on DragonFly. It does have "command" keyword.

This results in HOST_SH being set to the unrelated ps output.

Also the \t is not a TAB in that version of sed/regex. It is a literal 
letter "t".

So I used:

        [ -z "${HOST_SH}" ] && HOST_SH="$(
-               (ps -p $$ -o comm | sed -ne '2s/[ \t]*$//p') 2>/dev/null )"
+               (ps -p $$ -o command 2>/dev/null | sed -ne '2s/[        
].*$//p') 2>/dev/null )"
        # If nothing above worked, use "sh".  We will later find the

with space and real tab and followed by . (match any)

Second issue was:

checking build system type... 
unable to guess system type

I am sure a newer config.guess would suffice. Or should it just use a 
common good config.guess for all uses?

I tried to workaround this by replacing it with 

But then that failed with:

checking build system type... Invalid configuration 
`i386-unknown-dragonfly2.1.1': system `dragonfly2.1.1' not recognized
configure: error: /bin/sh 
i386-unknown-dragonfly2.1.1 failed

Home | Main Index | Thread Index | Old Index