Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: should I need to set LD_LIBRARY_PATH for X11R7 for pkg binaries now?

On 16/12/2008, at 9:48 AM, Paul Goyette wrote:

On Tue, 16 Dec 2008, George Michaelson wrote:

On 15/12/2008, at 7:02 PM, Quentin Garnier wrote:

On Mon, Dec 15, 2008 at 11:33:10AM +1000, George Michaelson wrote:
Since I went to X11R7 and x11-links, even simple programs like tvtwm
demand I set LD_LIBRARY_PATH to include X11R7 before they will run.
I pkg_delete and re-installed, to make sure.
Is this a bug? I expected that either the x11-links, or explicit
knowledge in the mk framework for pkgsrc would know about native X11R7 and include it in a statically located library path, but that didn't
seem to happen.
What pkgsrc tree are you using? Only HEAD knows about X11R7, and not

Well, after updating to X11R7, I rebuilt all of my packages from pkgsrc HEAD (some 240+ packages) and have had no problems. Everything just works.

It _was_ necessary to delete ALL of the old pkgsrc stuff and start from scratch.

thats probably my mistake.

I deleted almost everything, but not everything. (I pruned PKGPATH with x11/)

tvtwm doesn't link any libs outside of the X11 core set, so I was surprised that it demanded an explicit shared path, but it may well have been an associated dependency, not a direct X11 dependency


Home | Main Index | Thread Index | Old Index