Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xorg issue with 5.0_BETA and nVidia GeForce 2 card

Robert Elz wrote:
| >I've just tried out on 5.0_BETA/i386 for the first time, I used | >"X -configure" to create a test configuration file, and then ran the X | >server with that file. The server starts, but then gets stuck at some
  | >initialization point while the screen is still in that state where it
  | >has the grey background and the mouse cursor that's an "X".  It never
  | >gets past that point.  Killing the server leaves the console stuck in
  | >that state.  (I don't know if this is useful, but the mouse does
  | >respond while the X server is running.)
  | The very simple answer to my problem is that for whatever reason,
  | X -config <config file> doesn't work,

Actually, what you described is "does work", if you just start a
server and no clients, it is supposed to behave just like you
described.  The X server is responsible for restoring video state,
so if you kill it, and deny it the opportunity to do that, your display
will be wedged.   That all sounds like normal operation to me
(to exit rhe server in that state use Ctl-Alt-Bsp ... if that doesn't
work, and isn't disabled in the xorg.conf which it shouldn't be just after
being built via X -configure, that would be a bug.)

Aha, thanks.  This is just multiple user errors then.  When I ran
"X -configure", it said "To test the server, run 'X -config
/root/'", and I interpreted that incorrectly.  (I have a
dim memory of once starting something in X without specifying a window
manager, and ending up with twm by default, so I'd just assumed that's
what would happen here.  I must've used startx.  On top of that, I did
try and pull up man pages, but nothing came back.  But I didn't clue in
the man pages were installed but simply not in my default search path.)
Sorry about the noise, and thanks for the clarification.

  | But simply running startx with an .xinitrc referencing a
  | window manager of choice works fine.

Yes, then you're starting clients as well as the server.
That (or xdm or equiv) are how you're supposed to start X

That being the case, everything's working fine, and I'm enjoying using



Home | Main Index | Thread Index | Old Index