Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: can no longer build graphics/gle since glut was imported in base?

On Sun, Nov 23, 2008 at 10:26:40AM +0100, Geert Hendrickx wrote:
> Hi,
> since glut was imported in xsrc, and pulled up to netbsd-5, I can no longer
> build packages like xscreensaver that depend on it.  graphics/glut grew a
> file, hence graphics/gle no longer depends on the glut package,
> but fails with:
> checking for glutSwapBuffers in -lglut... no
> configure: error: Cannot find required glut library
> *** Error code 1

There is no problem with 5.99.02, which has the xorg glut:

checking for glutSwapBuffers in -lglut... yes
configure: creating ./config.status

Do you have by chance the pkgsrc glut package installed?

And what does config.log say why it fails?

Mine has this:

configure:9478: checking for glutSwapBuffers in -lglut
configure:9509: cc -o conftest -O2 -I/usr/pkg/include -I/usr/X11R7/include 
-I/usr/include -Wall -I/usr/pkg/include -I/usr/X11R7/include -I/usr/include 
-L/usr/pkg/lib -L/usr/X11R7/lib -Wl,-R/usr/X11R7/lib -L/usr/lib -Wl,-R/usr/lib 
-Wl,-R/usr/pkg/lib conftest.c -lglut  -lSM -lICE -lXmu -lXi -lXext -lXmu -lGLU 
-lGL  -L/usr/X11R7/lib -lX11  -lXext -lm >&5
configure:9512: $? = 0 

Did you install x11-links-0.41?


Home | Main Index | Thread Index | Old Index