Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: dk* drivers on NetBSD 5.0 (beta)-install

2008/11/6 vincent <>:
> Le 6 nov. 08 à 15:17, Michal Suchanek a écrit :
>> On 06/11/2008, vincent <> wrote:
>>> Hi folks,
>>> I am trying to install NetBSD on my new Late2008 MacBook (aluminium
>>> case).
>>> While I've managed to make space for a decent partition and to install
>>> rEFIt, the install kernel will not allow me to copy the code on a dk
>>> wedge:
>>> I correctly get wd0, dk0,1 and 2 messages but I cannot choose anything
>>> else
>>> than wd0 to install NetBSD on.
>> You can
>> a) build an install kernel w/o GPT support (just disable the single
>> option related to GPT)
> I've tried that. I'm stuck in the boot process: the kernel hangs somewhere;
> I guess it is somehow related to the same bug I encountered with my office
> DELL: this is a multiprocessor boot issue. I've tried to disable pckbd, but
> to no avail. What I cannot explain is why it booted normally once.
> Is there a way to disable multiprocessing?
> Besides, the bootable CD-Rom is NOT recognized by rEFIt, so I have to rely
> on the built-in way to boot other media, that is holding the C key down
> while booting. But then I lose the possibility to choose options at boot
> time, thus to disable dynamically multiprocessing, probably because the boot
> menu sees a lot of Cs coming out of the keyboard and takes that for a 0
> input.
I tried on an Inte Mac Mini (v1.1). rEFIt does recognize my CD-ROM just fine.
For me 64bit does not work at all but i386 MP does.

You can hold Alt (or Option or what you have painted on the key)
instead of C to get Apple's boot menu and select the CD there without
excessive key presses.

On the Apple boxes I have seen so far the keyboard part of the PC bios
emulation is more or less broken, though. You cannot type anything so
the NetBSD boot loader just times out (the timeout seems very short)
and things like isolinux keep waiting forever. I heard that the
emulation works on some macbooks so you you might have better luck
with this part.

>> b) install 4.01, build 5 BETA kernel w/o GPT support, and upgrade
> Unapplicable: 4.01 won't start. After a short while (still in the discovery
> of the peripherals), the console shuts down, the screen blanks and the
> computer emits beeps indefinitely. Looks like a memory problem.

That' what you get for working with too new hardware ;-)



Home | Main Index | Thread Index | Old Index