Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

initial xorg problems


I just upgraded my workstation from 4.99.72 with XFree86 to 5.0_BETA with
native  A few initial problems I noted:
(I moved away /usr/X11R6, and tried the following both with my old /etc/X11
config tree and a fresh one extracted from xetc.tgz)

- /etc/rc.d/xdm still invokes /usr/X11R6/bin/xdm.  Perhaps this file (and
  /etc.rc.d/xfs) should be moved to the xetc set instead?

- /usr/X11R7/man manpages are not in the default search path.

- xdm doesn't invoke my .xsession after login, I just get a single xterm.
  xinit and startx work properly though and start my usual session.

- with an UTF-8 locale (LC_CTYPE=nl_BE.UTF-8 or en_US.UTF-8), when I start
  an xterm it prints "Failed to open input method", and then takes another
  3 seconds to show the xterm window.  With LC_CTYPE unset, xterm starts

- long key presses don't repeat the key's input anymore, I have to press a
  key multiple times instead.

The first two are easy to fix, but for the latter three, I don't know what
causes them.  They always worked fine with native XF86 on the same box.

Any ideas?


Home | Main Index | Thread Index | Old Index