Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xD on sdmmc

Christoph Egger wrote:
> KIYOHARA Takashi wrote:
>> Hi! nonaka-san and all,
>> I wrote the ld_sdmmc.c.  It tested on GUMSTIX(evbarm) only.
>> First, you patch for nonaka's nbsd-sdmmc-20080512.diff.
>> Next, you re-patch.
> Hi,
> I have tried the first patch. It almost cleanly applied.
> I had to manually add sdmmcbus in sys/conf/files.
> I also had to manually add  include "dev/sdmmc/files.sdmmc"
> in sys/arch/amd64/conf/files.amd64 to not make config barf
> about unknown sdmmc
> After booting the amd64 kernel, I got this in dmesg:
> sdhc0 at pci1 dev 5 function 1: Ricoh 5C822 PCI-CardBus
> bridge/MS/SD/MMC/SC (rev. 0x22)
> sdhc0: interrupting at ioapic0 pin 9
> sdmmc0 at sdhc0
> Ricoh 5C843 PCI-CardBus bridge/SD/MMC/MMC+/MS/xD/Firewire (miscellaneous
> system, revision 0x12) at pci1 dev 5 function 2 not configured
> Ricoh 5C592 PCI-CardBus bridge/MS/SD/Firewire (miscellaneous system,
> revision 0x12) at pci1 dev 5 function 3 not configured
> Ricoh xD-Picture Card Controller (miscellaneous system, revision 0x12)
> at pci1 dev 5 function 4 not configured
> My Olympus Digital Camera uses xD-Picture Cards.
> Nonetheless, I plugged one in and nothing happened (I suppose this is
> expected since it doesn't support the other controllers).

I also tried the second patch. It applied cleanly.
dmesg output is the same.
Testing result with a xD-Picture Card is also the same.


Home | Main Index | Thread Index | Old Index