Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NFS lockups in Xen/amd64 -currentish?

Hash: SHA1


In a Xen environment where I run an amd64 DOM0 with either amd64 or i386pae DOMUs I ran into the problem that amd64 DOMUs could not NFS mount anything from the DOM0. As soon as they touched NFS they hang hard. Now, I know that NFS problems tend to make things hang, and it is sometimes hard to distinguish between "hang" as in "kernel is hung" or as in "kernel is waiting for something".

This was -current as of mid-August and as I was short on time I switched to using i386pae DOMUs instead, where NFS (against the same DOM0) worked just fine. So I never sorted out the NFS hang issue.

Fast forward to tonight.

I now have the need to use ipfilter/ipnat on the DOMUs and now I realize that I never upgraded the DOMU userland from 4.0-REL. I.e. my currentish i386pae DOMUs have been running on an old 4.0 userland, but that fails the kernel version check in the ipfilter tools.

So I upgrade the userland and I'm immediately stuck in the same NFS hang for the i386pae DOMUs that I had a few weeks ago for amd64 DOMUs.

As NFS works just fine with the old 4.0 userland I can only assume that the DOM0 NFS server (running amd64/current) is fine. And as NFS works fine with a current i386pae kernel and an old userland I would guess that that kernel is fine.

So as it is only with "current" userlands in the DOMUs (regardless of arch) that I have problems I have to suspect the userland.

Does anyone know of any recent NFS issues that cause hangs? The i386 userland is from August 28 and the amd64 userland is from August 11. Or does anyone have some bright idea what I might have done wrong (which would be fabolous, especially given the lack of clues)?



PS. I should add that my ability to debug right now is fairly limited as I'm departing tomorrow for the other side of the planet (the lower half) for two weeks. Therefore I'm very much in the "grateful for any sort of ugly workaround heard of" mode of operation...
Version: GnuPG v1.4.5 (Darwin)


Home | Main Index | Thread Index | Old Index