Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ALTqd vs PF/ALTQ

        Hello.  You must run both pf and altqd at the same time.  The pf(4)
must be loaded as an lkm.  You cannot use /etc/pf.conf to control altqd,
but you can write an altqd.conf file to set up your altq environment.  So,
yes, they're not integrated with each other, but they do work independently
in 4.0 just fine.

On Sep 8,  4:51pm, Swift Griggs wrote:
} Subject: Re: ALTqd vs PF/ALTQ
} On Mon, 8 Sep 2008, John R. Shannon wrote:
} > Altq worked with pf when I last used in in NetBSD.
} Well, it doesn't in 4.0:
} # sysctl -a | grep altq
} kern.drivers = [... snip ... whole bunch of stuff including altq]
} # pfctl -f /etc/pf.conf
} No ALTQ support in kernel
} ALTQ related functions disabled
} On my -current machine I don't see any options in GENERIC to enable pf's 
} altq. Does it "just work" once you compile in pseudo-device pf? Can I run 
} still altqd with pf ? Is one or the other considered deprecated at this 
} point or will they both go on being supported indefinitely?
} Thanks,
}    Swift
} -- 
} Swift Griggs -- <>
} Unix Systems Administrator
>-- End of excerpt from Swift Griggs

Home | Main Index | Thread Index | Old Index