Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: veriexecctl(8) segfaults when no argument is given

On Sun, Aug 31, 2008 at 11:43:30PM +0300, Stathis Kamperis wrote:
> * I filed a PR for this, so it won't get lost:
> * I've also filed a PR for -v flag not being documented in
> veriexecctl(8) man page:

Thanks for the reports.
> * I've come up with some locking issues. Veriexecctl goes into tstile
> state and renders the whole system unusable, ie all processes
> gradually become unresponsive and go into tstile state as well. It's
> 100% reproducible for me (only) under X environment: run an xterm and
> type 'veriexecctl load' a dozen consecutive times until it hangs. I'll
> come back with a useful trace.

Interesting.  I would like to see the traces from this.  Can you try
running a kernel with LOCKDEBUG to get some information about the
locking?  It sounds like processes are piling up on a held lock.

Brett Lymn
The information contained in this email and any attached files is
confidential to BAE Systems Australia. If you are not the intended
recipient, any use, disclosure or copying of this email or any
attachments is expressly prohibited.  If you have received this email
in error, please notify us immediately. VIRUS: Every care has been
taken to ensure this email and its attachments are virus free,
however, any loss or damage incurred in using this email is not the
sender's responsibility.  It is your responsibility to ensure virus
checks are completed before installing any data sent in this email to
your computer."

Home | Main Index | Thread Index | Old Index