Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: sony dsc t1 & other usb2 issues

On Fri, 15 Aug 2008, Anders Lindgren wrote:
I have never been able to use USB2 umass (UHCI/EHCI) in NetBSD; it has simply never worked on any computer I or my friends have ever had,

Despite having been one of the first OSs with USB support, I have had a lot of problems with USB/USB2 as well. I have had the best luck with Intel USB controllers, terrible luck with ATI (SB600 mobos), and mixed luck with VIA and nVidia controllers. I have also noticed that the file systems in use on the USB media seem to make a difference in terms of stability. I've had lots of lockups/filesystem-freezes with fat/vfat but in many cases I can take the same physical media, put FFS1 on it, and it works like a champ with no problems. I've also noticed that fat-based devices are excruciatingly slow (usually less than 1mb/s) compared with the same device under doze or Linux (usually 3-5 mb/s). This is NOT due to caching because I've run tests whereby I fill the entire device up (using SD cards and Maxtor external hard disk drives). Mounting async only seems to make fat lock up faster or freeze longer. Nonetheless, there are a few cases where USB2 & NetBSD perform very nicely. I have a Dell 530s with an Intel-based chipset that is smoking-fast with FFS2 and outperforms Linux on the same machine by some margin. I've seen fat/vfat slowness on this machine, but never lockups.

although I am happy to say it does appear to work on my new eeepc900.

Indeed it does on mine, too. However, it's painfully slow. I just installed -current on it (yesterday's cut) and I can't get it to crank out more than 1mb/s using an external Maxtor HDD that I get around 18-25 mb/s (at least on big blocked out sync-writes) on other machines. I know the eee900 is a bit on the slow side with it's 900Mhz Celeron, but something still seems rotten...

I've seen precisely the behaviour you describe with usb sticks and compact flash cards, but also complete IO deadlocks and system freezes.

Ditto. However, I've seen a lot fewer with NetBSD 4.0 and even less with -current. It seems the demons are slowly being exercised.

Slower OHCI devices (mice, keyboards, wacom tablet etc) however have always worked well for me.

I'd add to that list scanners via libusb/sane and in my case cameras accessed via gphoto. I'm a little slow to blame NetBSD when some digital camera doesn't work just right since I'm wondering how much time their engineers spend getting the UMASS functionality to work outside testing the bundled Windoze app.

Swift Griggs -- <>
Unix Systems Administrator

Home | Main Index | Thread Index | Old Index