Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Re: Eee PC, black screen after sleep


On Tue, Jun 24 2008 - 12:27, Jared D. McNeill wrote:
> On Tue, 24 Jun 2008, Joel CARNAT wrote:
>> Running 4.99.64 (GENERIC modified by sysutils/adjustkernel, plus ath0
>> patches and DRM enabled), my Eee PC 900 keeps a black console when coming
>> back from sleep. It is not frozen (I can blindly use 'sudo reboot').
>> I have tried "machdep.acpi_vbios_reset = 1" and "machdep.acpi_vbios_reset
>> = 0": same issue.
>> I have tried "machdep.acpi_beep_on_reset = 0": I don't hear a beep.
>> I have blindly tried "vbetool post": screen keeps black.
>> Running GENERIC does not allow entering sleep state because "Devices
>> without power management support: ath0".
>> Thoughts ?
>> Remarks ?
> Hi Joel --
> You need to have Xorg running when you go to sleep as on the EeePC 701,  
> keep acpi_vbios_reset set to 1. This has been tested with  
> xf86-video-intel-2.1.1 and newer.

erf... so simple... :-)

I tried and it worked.
I just had to use the brightness key (Fn-F3, Fn-F4) to get the screen back.
Any other key (Enter, Space, Num Lk, ...) or mouse move leave it black.

I'm using xf86-video-intel-2.3.0 and modular-xorg-server-


Attachment: pgpl5Px1hgnyZ.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index