Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: btsco(4) on -current

Jared D. McNeill wrote:
Hey folks --

I picked up a USB bluetooth adapter and headset, and I'm trying to get it to work on -current. ubt attaches:
Unfortunately, audiorecord records silence, and attempting to play an mp3 to /dev/sound1 results in silence as well. Doing eg. 'mpg123 -v' shows that the audio device isn't stalled. Has anybody had any luck with this stuff lately, or am I missing something obvious?

I just got around to playing with the ubt(4) I've had plugged into my Netra T1 for a few months the other night, and I've had just about the same experience with recording... however, playback works now and then. Actually, recording doesn't even get silence, the output file is just 32 bytes long (I presume that's just the AU header; man how soon we forget these things ;)).

About one out of 3 or 4 attempts at playback attempts actually produces sound, but that sound comes ~ 20 seconds+ after the 'audioplay' invocation. The rest seem to fail with 'audioplay: audio drain ioctl failed: Resource temporarily unavailable'.

My 'bthset' instance will also occasionally die with a 'Connection lost' message. It's easy to restart, but kinda annoying when it does lose the connection.. this might be related to fact that I've got other devices which are paired to the headset in the vicinity and they might grab the devices' attention.

Config is the same as yours (hw.ubt0.config=2 & scomtu=48); my headset connects on channel 1. My headset is a Plantronics Voyager 510 (PLT-510), which has worked with a bunch of other PCs / handhelds / phones without any problems, and the USB dongle is a TrendNet TBW-101UB (which worked fine with the headset when connected to a WinXP machine). This is all with 4.99.64 from ~ 5/28 on sparc64.


Home | Main Index | Thread Index | Old Index